| Advisory ID | github_osv/GHSA-68r2-fwcg-qpm8 |
| Aliases |
CVE-2025-24814
|
| Summary | Apache Solr vulnerable to Execution with Unnecessary Privileges Core creation allows users to replace "trusted" configset files with arbitrary configuration Solr instances that (1) use the "FileSystemConfigSetService" component (the default in "standalone" or "user-managed" mode), and (2) are running without authentication and authorization are vulnerable to a sort of privilege escalation wherein individual "trusted" configset files can be ignored in favor of potentially-untrusted replacements available elsewhere on the filesystem. These replacement config files are treated as "trusted" and can use "<lib>" tags to add to Solr's classpath, which an attacker might use to load malicious code as a searchComponent or other plugin. This issue affects all Apache Solr versions up through Solr 9.7. Users can protect against the vulnerability by enabling authentication and authorization on their Solr clusters or switching to SolrCloud (and away from "FileSystemConfigSetService"). Users are also recommended to upgrade to Solr 9.8.0, which mitigates this issue by disabling use of "<lib>" tags by default. |
| Status | Published |
| Exploitability | 0.5 |
| Weighted Severity | 6.5 |
| Risk | 3.2 |
| Affected and Fixed Packages | Package Details |
| Introduced and Fixed Package Commit Patches | Package Commit Patches Details |
| System | Score | Found at |
|---|---|---|
| cvssv4 | 7.2 | https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2025/01/GHSA-68r2-fwcg-qpm8/GHSA-68r2-fwcg-qpm8.json |
| generic_textual | HIGH |
| Reference id | Reference type | URL |
|---|---|---|
| https://github.com/apache/solr | ||
| https://github.com/apache/solr/commit/f492e24881c5724a1b1baecfc9549e2cb0257525 | ||
| https://issues.apache.org/jira/browse/SOLR-16781 | ||
| https://security.netapp.com/advisory/ntap-20250214-0002 | ||
| http://www.openwall.com/lists/oss-security/2025/01/26/1 | ||
| CVE-2025-24814 | https://nvd.nist.gov/vuln/detail/CVE-2025-24814 | |
| gl291pn8x9f9n52ys5l0pc0b6qtf0qw1 | Advisory | https://lists.apache.org/thread/gl291pn8x9f9n52ys5l0pc0b6qtf0qw1 |
No EPSS data available for this advisory.
| Patch URL | |
|---|---|
| There are no known patches. | |
| Attack Vector (AV) | Attack Complexity (AC) | Attack Requirements (AT) | Privileges Required (PR) | User Interaction (UI) | Vulnerable System Impact Confidentiality (VC) | Vulnerable System Impact Integrity (VI) | Vulnerable System Impact Availability (VA) | Subsequent System Impact Confidentiality (SC) | Subsequent System Impact Integrity (SI) | Subsequent System Impact Availability (SA) |
|---|---|---|---|---|---|---|---|---|---|---|
network adjacent local physical |
low high |
none present |
none low high |
none passive active |
high low none |
high low none |
high low none |
high low none |
high low none |
high low none |
Vector: SSVCv2/E:N/A:N/T:P/P:M/B:A/M:M/D:T/2025-01-27T14:10:58Z/
Decision: Track
Source URL: https://github.com/cisagov/vulnrichment/blob/develop/2025/24xxx/CVE-2025-24814.json
Source Advisory: vulnrichment/CVE-2025-24814
[{'Exploitation': 'none'},
{'Automatable': 'no'},
{'Technical Impact': 'partial'},
{'Mission Prevalence': 'minimal'},
{'Public Well-being Impact': 'material'},
{'Mission & Well-being': 'medium'}]