Advisory details:
gitlab / maven/org.apache.tomcat/tomcat/CVE-2026-59084
| Advisory ID | gitlab/maven/org.apache.tomcat/tomcat/CVE-2026-59084 |
| Aliases |
CVE-2026-59084
|
| Summary | Insufficient Technical Documentation vulnerability in Apache Tomcat since the requirements to securely configure the EncryptInterceptor were not clearly documented. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.23, from 10.1.0-M1 through 10.1.56, from 9.0.13 through 9.0.119, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.24, 10.1.57 or 9.0.120 which fix the issue. |
| Status | Published |
| Exploitability | 0.5 |
| Weighted Severity | 0.0 |
| Risk | |
| Affected and Fixed Packages | Package Details |
| Introduced and Fixed Package Commit Patches | Package Commit Patches Details |
| System | Score | Found at |
|---|---|---|
| There are no known severity scores. | ||
| Reference id | Reference type | URL |
|---|---|---|
| https://lists.apache.org/thread/7w9746ootcxo0gvx26xjpw80l31f1qw7 | ||
| CVE-2026-59084 | https://nvd.nist.gov/vuln/detail/CVE-2026-59084 |
No EPSS data available for this advisory.
| Patch URL | |
|---|---|
| There are no known patches. | |
There are no SSVC decisions available.