Advisory details:
ruby_advisory_db / gems/twitter-bootstrap-rails/CVE-2019-8331
| Advisory ID | ruby_advisory_db/gems/twitter-bootstrap-rails/CVE-2019-8331 |
| Aliases |
CVE-2019-8331
GHSA-9v3m-8fp8-mj99 |
| Summary | twitter-bootstrap-rails vulnerable to Cross-Site Scripting (XSS) The seyhunak/twitter-bootstrap-rails gem includes a vendored version of the Bootstrap JavaScript library. In Bootstrap before 3.4.1 and 4.3.x before 4.3.1, XSS is possible in the tooltip or popover data-template attribute. The most recent version of this gem, 5.0.0, includes Bootstrap v 3.3.6. All versions of Bootstrap before v 3.4.1 are affected by this vulnerability. All versions of this gem are affected. # Workarounds Until this gem is updated to use Bootstrap v3.4.1, users can replace it with the official Twitter-maintained gems, `bootstrap-sass` (version 3.4.1) or `bootstrap` (bootstrap 4 and 5). |
| Status | Published |
| Exploitability | 0.5 |
| Weighted Severity | 0.0 |
| Risk | |
| Affected and Fixed Packages | Package Details |
| Introduced and Fixed Package Commit Patches | Package Commit Patches Details |
| There are no known CWE. |
| System | Score | Found at |
|---|---|---|
| cvssv2 | 4.3 | |
| cvssv3 | 6.1 |
| Reference id | Reference type | URL |
|---|---|---|
| GHSA-9v3m-8fp8-mj99 | https://github.com/advisories/GHSA-9v3m-8fp8-mj99 |
No EPSS data available for this advisory.
| Patch URL | |
|---|---|
| There are no known patches. | |
There are no SSVC decisions available.