Staging Environment: Content and features may be unstable or change without notice.

Advisory Weakness Curation

CVE-2021-33036

Progress 0 / 0

Advisory Summaries

github_osv/GHSA-58jx-f5rf-qgqf

User account escalation in Apache Hadoop In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate to yarn user can possibly run arbitrary commands as root user. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.

gitlab/maven/org.apache.hadoop/hadoop-hdfs-native-client/CVE-2021-33036

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate to yarn user can possibly run arbitrary commands as root user. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.

gitlab/maven/org.apache.hadoop/hadoop-yarn-server-common/CVE-2021-33036

User account escalation in Apache Hadoop In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate to yarn user can possibly run arbitrary commands as root user. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.