Staging Environment: Content and features may be unstable or change without notice.

Advisory Weakness Curation

CVE-2021-37404

Progress 0 / 0

Advisory Summaries

github_osv/GHSA-rmpj-7c96-mrg8

Apache Hadoop heap overflow before v2.10.2, v3.2.3, v3.3.2 There is a potential heap buffer overflow in Apache Hadoop libhdfs native code. Opening a file path provided by user without validation may result in a denial of service or arbitrary code execution. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.

gitlab/maven/org.apache.hadoop/hadoop-common/CVE-2021-37404

Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') There is a potential heap buffer overflow in Apache Hadoop libhdfs native code. Opening a file path provided by user without validation may result in a denial of service or arbitrary code execution. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.

gitlab/maven/org.apache.hadoop/hadoop-hdfs-native-client/CVE-2021-37404

Buffer Copy without Checking Size of Input ('Classic Buffer Overflow') There is a potential heap buffer overflow in Apache Hadoop libhdfs native code. Opening a file path provided by user without validation may result in a denial of service or arbitrary code execution. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.