Staging Environment: Content and features may be unstable or change without notice.

Advisory Weakness Curation

CVE-2014-3742

Progress 0 / 0

Advisory Summaries

github_osv/GHSA-cqr7-78pj-3g7j

File Descriptor Leak Can Cause DoS Vulnerability in hapi Versions 2.0.x and 2.1.x of hapi are vulnerable to a denial of service attack via a file descriptor leak. When triggered repeatedly, this leak will cause the server to run out of file descriptors and the node process to die. The effort required to take down a server depends on the process file descriptor limit. No other side effects or exploits have been identified. ## Recommendation - Please upgrade to version 2.2.x or above as soon as possible.

gitlab/npm/hapi/CVE-2014-3742

File descriptor leak can cause DoS vulnerability A file descriptor leak that when triggered repeatedly will cause the server to run out of file descriptors and the node process to die. The effort required to take down a server depends on the process file descriptor limit. No other side effects or exploits have been identified.