| Advisory ID | vulnrichment/CVE-2025-58360 |
| Aliases | |
| Summary | GeoServer is an open source server that allows users to share and edit geospatial data. From version 2.26.0 to before 2.26.2 and before 2.25.6, an XML External Entity (XXE) vulnerability was identified. The application accepts XML input through a specific endpoint /geoserver/wms operation GetMap. However, this input is not sufficiently sanitized or restricted, allowing an attacker to define external entities within the XML request. This issue has been patched in GeoServer 2.25.6, GeoServer 2.26.3, and GeoServer 2.27.0. |
| Status | Published |
| Exploitability | 0.5 |
| Weighted Severity | 0.0 |
| Risk | |
| Affected and Fixed Packages | Package Details |
| Introduced and Fixed Package Commit Patches | Package Commit Patches Details |
| System | Score | Found at |
|---|---|---|
| cvssv3.1 | 8.2 | |
| ssvc | Attend |
| Reference id | Reference type | URL |
|---|---|---|
| https://osgeo-org.atlassian.net/browse/GEOS-11682 | ||
| GHSA-fjf5-xgmq-5525 | https://github.com/geoserver/geoserver/security/advisories/GHSA-fjf5-xgmq-5525 |
| Data source | Metasploit |
|---|---|
| Description | This module exploits an XML External Entity (XXE) vulnerability in GeoServer via the WMS GetMap operation. The vulnerability allows reading arbitrary files from the server's file system by injecting an XXE entity in the SLD (Styled Layer Descriptor). Affected versions: - GeoServer >= 2.26.0, <= 2.26.1 - GeoServer <= 2.25.5 The file content is returned in the error message when the layer name contains the XXE entity reference. |
| Note | Stability: - crash-safe Reliability: [] SideEffects: - ioc-in-logs |
| Ransomware campaign use | Unknown |
| Source publication date | Nov. 25, 2025 |
| Source URL | https://github.com/rapid7/metasploit-framework/tree/master/modules/auxiliary/gather/geoserver_wms_getmap_xxe_file_read.rb |
| Data source | KEV |
|---|---|
| Date added | Dec. 11, 2025 |
| Description | OSGeo GeoServer contains an improper restriction of XML external entity reference vulnerability that occurs when the application accepts XML input through a specific endpoint /geoserver/wms operation GetMap and could allow an attacker to define external entities within the XML request. |
| Required action | Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable. |
| Due date | Jan. 1, 2026 |
| Note | This vulnerability affects an open-source component, third-party library, or a protocol used by different products. For more information, please see: https://github.com/geoserver/geoserver/security/advisories/GHSA-fjf5-xgmq-5525 ; https://osgeo-org.atlassian.net/browse/GEOS-11922 ; https://nvd.nist.gov/vuln/detail/CVE-2025-58360 |
| Ransomware campaign use | Unknown |
No EPSS data available for this advisory.
| Patch URL | |
|---|---|
| There are no known patches. | |
| Attack Vector (AV) | Attack Complexity (AC) | Privileges Required (PR) | User Interaction (UI) | Scope (S) | Confidentiality Impact (C) | Integrity Impact (I) | Availability Impact (A) |
|---|---|---|---|---|---|---|---|
network adjacent_network local physical |
low high |
none low high |
none required |
unchanged changed |
high low none |
high low none |
high low none |
Vector: SSVCv2/E:A/A:Y/T:P/P:M/B:A/M:M/D:A/2025-12-12T04:55:43Z/
Decision: Attend
Source URL: https://github.com/cisagov/vulnrichment/blob/develop/2025/58xxx/CVE-2025-58360.json
Source Advisory: vulnrichment/CVE-2025-58360
[{'Exploitation': 'active'},
{'Automatable': 'yes'},
{'Technical Impact': 'partial'},
{'Mission Prevalence': 'minimal'},
{'Public Well-being Impact': 'material'},
{'Mission & Well-being': 'medium'}]