| Advisory ID | vulnrichment/CVE-2025-62164 |
| Aliases | |
| Summary | vLLM is an inference and serving engine for large language models (LLMs). From versions 0.10.2 to before 0.11.1, a memory corruption vulnerability could lead to a crash (denial-of-service) and potentially remote code execution (RCE), exists in the Completions API endpoint. When processing user-supplied prompt embeddings, the endpoint loads serialized tensors using torch.load() without sufficient validation. Due to a change introduced in PyTorch 2.8.0, sparse tensor integrity checks are disabled by default. As a result, maliciously crafted tensors can bypass internal bounds checks and trigger an out-of-bounds memory write during the call to to_dense(). This memory corruption can crash vLLM and potentially lead to code execution on the server hosting vLLM. This issue has been patched in version 0.11.1. |
| Status | Published |
| Exploitability | 0.5 |
| Weighted Severity | 0.0 |
| Risk | |
| Affected and Fixed Packages | Package Details |
| Introduced and Fixed Package Commit Patches | Package Commit Patches Details |
| CWE-20 | Improper Input Validation |
| CWE-123 | Write-what-where Condition |
| CWE-502 | Deserialization of Untrusted Data |
| CWE-787 | Out-of-bounds Write |
| System | Score | Found at |
|---|---|---|
| cvssv3.1 | 8.8 | |
| ssvc | Track |
| Reference id | Reference type | URL |
|---|---|---|
| https://github.com/vllm-project/vllm/commit/58fab50d82838d5014f4a14d991fdb9352c9c84b | ||
| https://github.com/vllm-project/vllm/pull/27204 | ||
| GHSA-mrw7-hf4f-83pf | https://github.com/vllm-project/vllm/security/advisories/GHSA-mrw7-hf4f-83pf |
No EPSS data available for this advisory.
| Patch URL | |
|---|---|
| There are no known patches. | |
| Attack Vector (AV) | Attack Complexity (AC) | Privileges Required (PR) | User Interaction (UI) | Scope (S) | Confidentiality Impact (C) | Integrity Impact (I) | Availability Impact (A) |
|---|---|---|---|---|---|---|---|
network adjacent_network local physical |
low high |
none low high |
none required |
unchanged changed |
high low none |
high low none |
high low none |
Vector: SSVCv2/E:N/A:N/T:T/P:M/B:A/M:M/D:T/2025-11-24T17:15:13Z/
Decision: Track
Source URL: https://github.com/cisagov/vulnrichment/blob/develop/2025/62xxx/CVE-2025-62164.json
Source Advisory: vulnrichment/CVE-2025-62164
[{'Exploitation': 'none'},
{'Automatable': 'no'},
{'Technical Impact': 'total'},
{'Mission Prevalence': 'minimal'},
{'Public Well-being Impact': 'material'},
{'Mission & Well-being': 'medium'}]